Algolab Photo Vector
Introduction: What Customers use Photo Vector for?
Photo Vector (PV) is a handy tool for designers to create, cleanup, make fast
corrections, edit designs with or without further conversion to vector formats. It
may be especially useful for designs on fabric, textile, jacquard, carpets, mats,
vinyl and other materials. Photo Vector is your best choice to cleanup scanned
designs and edit colors.
PV helps to create quality vector graphics from raster images. It’s vector output is
in use as input to vector image editors, CAD software to cut signs, generate CNC
code etc.
PV provides unique capabilities in Color Reduction creating Photo Impressionist
color effects.
Get special photo effects with PV increasing and/or changing impression created
by photos converting them into vector pictures that look like impressionist art!
Visit our WEB site to see such special effects.
PV creates outlines: it converts 2D raster shapes into vector ones and it’s output
vector files consist of closed color paths.
To create black and white center lines and recognize arcs, lines and curves one
may want to try our other product Algolab Raster to Vector Conversion Toolkit
which converts scanned architectural, mechanical drawings and designs, maps
and more to vector format for use in CAD and drawing programs. It also
incorporates a new advanced Fine Line Technology and creates perfectly looking
shapes and figures. Visit our WEB site to see what does it mean:
http://www.algolab.com/Fine_Line/Fine_Lines.htm

What Customers use Photo Vector for
AlgoLab Photo Vector is a raster to vector conversion, image editing, and image
processing software for Windows. PV can be used as a stand along application
or with Jasc Paint Shop Pro, Adobe Photo Shop, Adobe Illustrator, Corel Draw,
Zonner and other image editors and CAD software extending their functionality.
Vector output formats include Adobe Illustrator, Windows Metafile, AutoCAD dxf
and Jasc Paint Shop Pro.
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PV is especially useful for Jasc Paint Shop Pro users as it provides vector output
in psp format. If you use or consider to use PSP vector capabilities then PV is
just made for you.
With a single mouse click one can convert a color raster image to scalable vector
artwork with any desirable accuracy depending on chosen settings.
There is an option to use a single copy of this software for free in big networks.
Any feedback is very welcome! If you would like to see more features or an
enhancement of existing ones just let us know and we will do our best to make
these features available.

How PV works
The image processing includes a new unique shaping operation converting blur
shapes into distinct ones, flexible color reduction and cleaning as well as a
precise vectorizing. Bitmap and palette editing tools enable one to enhance
processed images manually. Visit our WEB site at http://www.algolab.com to find
details and to view processed image galleries.
There are two steps in conversion of raster into vector format. The first step is a
preparation or preprocessing the image before conversion. This preprocessing
includes the following operations: Shaping, Color Reduction and Cleaning. The
second step is the conversion operation Vectorizing itself.
Shaping (optional) provides an image to get better defined boundaries of color
shapes and more homogeneous colors inside the shapes.
Color Reduction creates an appropriate reduced palette for an image and
replaces original colors with the colors of the palette.
Cleaning removes small spots and merge small details into bigger shapes that
have close colors.
PV is in use not only for raster to vector conversion but for raster image
processing as well when one needs a raster image to be composed of clean solid
color shapes with smooth well defined boundaries and to have few or selected
number of colors. In this respect the preprocessing may be considered as a
Color Reduction in a broad sense that includes the above mentioned three
operations. Raster preprocessed image files may serve as a final output in such
case.
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Installation
Download the file PtVector.exe file. Run it and follow prompts. It will install the
application for an evaluation period of 10 days. After that period the “save” file
operation is disabled.
Registered users receive the registration key via e-mail shortly after the
purchase. To register open About dialog box from Help menu item, press
Register button and fill the registration fields.

Test
Open the supplied test image butterfly.jpg and press the toolbar button
“Sequence of Operation”. The following operations Shaping, Color Reduction,
Cleaning and Vectorizing will be applied to the image.
One should see the processed raster image covered with outlines. Save the
result as a vector file in emf, wmf or other vector format using the “save as”
menu item.
Open the saved emf or wmf file using Photo Vector to ensure that the result is
correct. Then one may want to open the saved vector file with an application able
to edit vector images.

Registration
One may want to buy a license for Algolab Photo Vector in our online store. We
will send the registration key by e-mail normally within 12 hours. Then from Help
menu item open About dialog and press Register button. Copy and past
registration information in appropriate fields of the registration dialog.
There is an option to register a single copy of this software for free in big
network.

Overview of Basic Operations with Images
Open-Save file operations. The application can open raster and vector image
files of several formats. An open vector image is converted into bitmap and
displayed on the screen. Then it may be processed and/or vectorized.
One can save a processed image in a raster format before the last vectorizing
operation takes place. After vectorizing operation the raster output is disabled
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and the vector output is enabled. To save image in a raster format in this case
one can first use undo operation that enables raster output again.
Zoom tool can be activated with + or - key or from View menu item. Click left and
right mouse buttons to zoom in and zoom out.
Move image tool can be activated with H key or from View menu item.
To switch between original and processed images use Ctrl-Tab hot key or
View=>Switch menu item.
Attention! When switched to the original bitmap the toolbar buttons become
disabled. To enable them switch back to the preprocessed image.

File Formats
Photo Vector saves vector files in “ai” ( Adobe Illustrator ), “emf”, “wmf” ,”dxf” (
AutoCAD ) and “psp”(Jasc Paint Shop Pro) formats.
AlgoLab Photo Vector supports read and write operations for raster “bmp”
(Windows bitmap), “jpeg”, “png” (Portable network graphics), and vector “wmf”
(Windows metafile format),“emf” (Enhanced metafile format ) file formats. When
loaded “wmf” and “emf” files are converted into an internal bitmap format.
With the help of External Bitmap Editor one can load and save raster files in any
other formats.
See also Output File Options.

Output File Options
The output file settings can be reached from the menu item
File=>Settings=>Advanced. To activate selected options press “OK” button in the
Settings dialog. The below options may be available for some of the file formats.
Color – switches between color shapes and black/white outlines.
Background – turns background On/Off. To select the background color make
sure that the image is not vectorized yet. Otherwise press Undo button. Then
open Edit=> Bitmap and Palette menu item. For more information see Edit
Bitmap and Palette Toolbox.
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File by Color – when selected provides output into the number of automatically
created files. Each file contains all shapes of one color. Additionally a text file is
created with the list of output files and colors. The names of output files are
derived from the name defined in the “Save as” dialog. For example if the palette
of the image contains 3 colors, the name is “Fname” and the output format is dxf
then the following files will be created: Fname.txt, Fname1.dxf, Fname2.dxf,
Fname3.dxf.
Line Width – selects line width in output files.

Automatic Raster to Vector Conversion
Load a raster image. To ensure that the default settings are set select menu item
File => Settings, click Default and OK buttons. Then press Sequence of
Operations toolbar button. The application will run consequently Shaping, Color
Reduction, Cleaning and Vectorizing engines. One should see processed image
with outlines.
To evaluate the quality of conversion switch between the resulting image and the
original one from menu item View => Switch or with the hot keys Ctrl-Tab.
If the quality is suitable save the vector file using the menu item File => Save As.
Otherwise there are several options to improve quality:
to load or select new settings and repeat computations. For more
information see Settings;
to use Undo affecting the last operation. Then the image after Cleaning
will be seen on the screen. Activate Palette and Bitmap Edit Dialog with
the help of Edit => Bitmap and Palette menu item. Edit the processed
image. Switching between processed and original images with the menu
item View => Switch or with the hot key Ctrl-Tab may be useful. When an
appropriate quality of the processed image will be reached convert it into
vector format pressing Vectorizing toolbar button;
to reload image with Reload Image toolbar button and go step by step
over operations using Undo and changing settings when necessary.

Automatic Color Reduction
Load a raster image. To ensure that the default settings are set select menu item
File => Settings, click Default, then uncheck Vectorizing check box and press OK
button. The Sequence of Operations is now defined to consist of Shaping, Color
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Reduction and Cleaning without Vectorizing. Then press Sequence of Operations
toolbar button. One should see processed image without outlines.
To evaluate the quality of color reduction switch between the resulting image and
the original one from the menu item View => Switch or with the hot keys Ctrl-Tab.
If the quality is suitable save the raster file using the menu item File => Save As
in an appropriate raster format. Otherwise there are several options to improve
quality that are described in the section Automatic Raster to Vector Conversion.
Attention: When the image is vectorized the raster output is disabled. Use Undo
to return one step back and enable raster output.

Automatic Raster to Vector Conversion
Skipping Preprocessing
There is an automatic analysis of every loaded image if it is simple enough to be
vectorized without preprocessing. If so Cleaning and Vectorizing toolbar buttons
become enabled from the very beginning.
Preprocessed images are normally simple enough to pass this test. So one may
want to save a preprocessed image in bmp or png format to be able to work with
the same image later.
Settings
To load or save settings press “Load” or “Save” button respectively. Use
“Advanced” button to set output parameters for various file formats. Settings are
saved on exit.
Conversion of a raster image into a vector one may be done in two steps:
preprocessing and vectorizing.
Preprocessing prepares an image for conversion simplifying it: makes a shape to
have a solid color with better defined boundary, reduces number of colors and
cleans the image removing small spots.
Vectorizing converts a preprocessed image one to one into a tree of outlines so
that each detail which is composed of pixels of exactly the same color is
represented by an outline even if this detail consists of one pixel.
Preprocessing consists of the following operations: Shaping (optional), Color
Reduction and Cleaning that can be run by pressing the toolbar buttons with the
same names on the front panel of the application.
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Shaping is intended to make shapes more distinct by supplying them with a
better defined boundary and homogenized interior.
Border Sensitivity changes an inner threshold that defines what pixel to be
considered as belonging to boundary or to interior of some shape. Less is border
sensitivity less is number of boundaries formed with this operation and simpler
the processed image becomes.
Color Reduction reduces the number of colors used in an image. It consists of
Palette Creation and Replacement of Bitmap Colors with closest ones found in
the palette. Additional options are available from the manually controlled color
reduction that may be activated from Edit =>Bitmap and Palette menu item.
Tolerance of Color Reduction is related to Palette Creation. Larger tolerance is
less is the number of colors in the palette as more of them are merged into one
color of the resulting palette.
The checkbox “Optimal” provides switch between determined by the engine
optimal number of colors in the palette and the number predefined by user that is
set in the “Max Number of Colors” edit box.
Cleaning is intended to clean up an image removing small spots and merging
adjacent details of close colors.
Spot Tolerance defines the size of spots to be removed. Less tolerance is more
spots remain.
Color Tolerance defines the color difference of details to be merged into one
shape. Less tolerance is more details remain.

Vectorizing converts preprocessed bitmap into a tree of outlines composed of
bezier curves. It includes a step of conversion of outlines composed of straight
segments (bitmap outlines) into bezier curves.
Tolerance of Bezier Converter defines the precision with which bezier curves
approximate bitmap outlines. Less tolerance is more close bezier curves are to
the bitmap outlines and less smooth these bezier curves are.
Sequence of Operations is related to the toolbar button with the same name that
runs consequently the operations defined in this setting box.
Preferences
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Here Preferences are such parameters of the package that normally may be
chosen the same for all images.
Use Browse button to select External Bitmap Editor

Edit Bitmap
The Vectorizing is an exact operation that constructs outlines of shapes
composed of pixels of exactly the same color. Pixels of different colors are
considered as belonging to different shapes. So in the most the quality of the
conversion is defined by preprocessing and the best way to improve quality is to
improve the quality of preprocessing. One of the way to do this is to provide
manual editing of preprocessed image when necessary.
There are simple tools to edit processed raster images. These tools are available
after the Cleaning operation takes place. The dialog with toolbox can be
activated from Edit => Bitmap and Palette menu item.
To switch between current processed image and the original one use
View=>Switch menu item or Ctrl-Tab hot key.
To select a color just click with the right or left mouse button on the image or the
palette. It may be done as well with the color selection dialog box. To activate
this box click the color button located in the middle of Edit Bitmap and Palette
dialog. The selected color is shown in the top left color box of the dialog Edit
Palette and Bitmap. One can see the closest color of the palette in the top right
color box.
Attention! The tools Pencil and Flood use the color of the palette which is the
closest one to the selected color, not the selected one. This closest color is
shown in the top right color box of the dialog. It can coincide or not with the
selected color. To use the selected color first add it to the palette.
The following steps may be used to make corrections to the processed image:
·
Find missing detail. Switching between the original and processed image
with Ctrl-Tab hot key one can find a missing detail in the processed image that
should be restored.
·

Select the tool. Select the Pencil tool

·
Select a color for of the missing detail. Switch to the original image and
right mouse click on that detail to select it’s color. Take a look at the top right
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color box containing a color which is the closest to the selected one. Drawing will
be done using this closest color, not the selected one. If the closest color is not
suitable then select an appropriate color from the palette. If the palette does not
contain an appropriate color add a new one to the palette.
·
Redraw missing detail. The missing detail may be redrawn on the
processed or original image. In the both cases only the processed image is
affected. The original image remains unchanged. Let us shortly discuss
redrawing using the original image. Make sure that the original image is shown
on the screen. Redraw the missing detail with the Pencil tool on the original
image simply covering this detail with the Pencil scratches. The drawn pixels are
stored in a special temporary layer and do not affect the original image. Then
switch images with Ctrl-Tab hot key so that the processed image to be shown on
the screen. The contents of the temporary layer will be applied to the processed
image that gives the missing detail.
Attention! One may draw with the Pencil tool on processed or original image. In
any case original image remains unchanged. When drawing on the original
image the drawn scratches will be projected down on the processed image next
time the original image is switched to the processed one.
In contrast to the Pencil tool the Flood tool may be applied to the processed
image only.
Edit Bitmap and Palette Toolbox
There are tools to edit palette and raster image (bitmap). These tools can be
activated from Edit => Bitmap and Palette menu item.
Edit Palette
The palette editing is enabled before vectorizing. If vectorizing is done and black
outlines over image are visible then just press Undo to enable palette editing.
During the palette editing process all other options are disabled. When editing is
finished press the button “Replace Bitmap Colors” to apply the edited palette to
the bitmap or press “Undo” to return to the state before editing.
When one presses “Color reduction” toolbar button two operations Palette
Creation and Replace Bitmap Colors take place automatically. The Edit Bitmap
and Palette dialog enables one to do these operations manually with more
flexibility.
The palette is a set of colors used in a bitmap. One can create a palette with the
help of the engine pressing the “Create” button with chosen tolerance or
compose palette manually. The palette will be shown by numbered color
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rectangles. Then this palette can be edited. To delete a color from the palette
select this color by mouse click on the color rectangle and press “Del” button. To
delete all colors from the palette starting from the selected one press “Del tail”.
To select a color just click with the left or right mouse button on the image or
palette. The selected color appears in the top left color box. The closest color of
the palette appears in the right top color box. If a color coincides with some color
of the palette it has an appropriate number.
To add selected color to the palette press “Add” button.
To replace bitmap colors with colors of the palette press “Replace Bitmap Colors”
button. Each pixel of the bitmap will be replaced with the closest color of the
palette.
This toolbox provides unique Special Color Reduction Capabilities. Colors in the
palette are ordered not by popularity but by representatively. This means that if
one wish for instance the image to consist from only 5 colors then the first 5
colors in the palette represent an optimal choice for such 5 color palette. All that
remains is to remove the tail from the palette starting from color #6 with the help
of “Del tail” button.
To provide better results of the color reduction it can be done in several
iterations. If after creation of the palette there are too many colors, remove a half
of them with “Del tail” button, then press “Replace bitmap colors” button, and
after that press “Cleaning” button on the main toolbar. Then press “Create”
button on the editing toolbar and repeat the operations with “Del tail” and so on.
At the end when the number of colors are reduced almost to the desirable small
number remove too close colors from the palette with “Del” button and apply the
palette with “Replace bitmap colors” button to finish reduced palette creation.
Select Background Color
To set background color press “Set” button. The selected color shown in the top
left color box will be set as the background color.
Edit Bitmap
The options to edit bitmap are enabled when the cleaning is done but vectorizing
is not applied yet. To edit bitmap after vectorizing (when black outlines are visible
on the screen) just press Undo.
The tools Pencil and Flood are enabled after Cleaning operation or if the image is
simple enough. The checks of image simplicity are done when image has been
loaded and after color replacement operation.
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These tools can be activated from the keyboard as well with the keys P and F
respectively when the toolbox is visible. One can select a color without change of
the tool with the help of the right mouse click.
One can switch between current processed image and the original one from
View->Switch menu item or Ctrl-Tab hot key. What is more one can draw with the
pencil over the original image: the resulting pixels are stored in a special layer
that will be applied to the processed bitmap next time it is switched on. The
original image does not change. It may be useful to correct processed image if
previous processing provided undesirable changes in comparison with the
original image.
Attention! When switched to the original bitmap the toolbar buttons become
disabled. To enable them switch back to the preprocessed image.
External Bitmap Editor
External bitmap editor may be used to extend the functionality of the package. It
can be reached from Edit menu. MS Paint is used by default. With the help of
Browse button from File =>Preferences menu one may want to select another
editor like Adobe PhotoShop.
If the external editor has been called when an image was loaded to Photo Vector
then the editor displays the image. To return back to Photo Vector with edited
externally image it is sufficient to close the image window in the editor or the
editor itself and reply “yes” when prompted “save changes?”
Attention: If one saves changes in the external editor using “save as” option then
he or she defines a new path and/or name of the saved image. In this case Photo
Vector does not know that name or path and one has browse over directories to
open that file manually from PV.
Free BIGNET license
One can use a single copy of Algolab Photo Vector for free in a network
containing 40 or more computers. See details below. We provide this option to
promote Algolab Photo Vector for use in medium and big companies. Feel free to
let your friends know about this option that will save them a lot of time for free in
cleaning up, making fast corrections, editing and vectorizing designs with this
proven handy designer’s tool. Just download this software from
http://www.algolab.com and use it!
For registration use the key FREE_KEY_FOR_BIGNET. Just open the
registration dialog from About dialog, copy and past this key in an appropriate
field.
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